Centos 5 server not supported

Jul 26, 2012 at 10:36 AM

I've installed the Centos 5 MP however after the Discovery Wizard finds my host it lists the status as Unsupported. In the Details popup it claims:

 

Failed to find a matching supported agent instance in the imported management packs.

Import the Management Pack(s) for this platform in order to discover this computer.

 

I can see the Centos 5 MP in my list of Management Packs so I know it's there.

Looking through the XML of the MP I see the following in the x86_64 InstanceSetting section:

<Setting>
<Name>$MPElement[Name="Unix!Microsoft.Unix.SupportedAgent"]/Arch$</Name>
<Value>i386_64</Value>
</Setting>

Thinking that the value looks odd and should in fact be x86_64 I tried changing the value and re-importing the MP however this still didn't work.

For what it's worth I have previously imported the Centos 6 MP and that seems to work well.

Aug 16, 2012 at 3:26 PM

I have the exact same problem.  Did anyone find a resolution?

Aug 17, 2012 at 1:07 AM
Edited Sep 15, 2012 at 12:09 AM
In the end we found no solution but since we were upgrading to CentOS 6 anyway it wasn't a priority.
I see that SCOM 2012 SP1 will contain official support for CentOS 5 and 6 so this problem is likely to go away anyway.